Back to overview
Downtime
zentic.cc Domain Expired
Apr 21, 2026 at 8:34pm UTC
Affected services
Website Status
Resolved
Apr 23, 2026 at 3:44am UTC
Renewed domain registration.
Affected services
Created
Apr 21, 2026 at 8:34pm UTC
Domain registration for zentic.cc expired. Server and website are inaccessible through zentic.cc.
Affected services